哈尔滨中税电话:势线指标公式

来源:百度文库 编辑:音乐简谱网 时间:2019/10/15 20:33:09
趋势线指标公式

VAR1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR2A:=((VAR27+VAR26+VAR20)/3+165)/4;
VAR2B:=(EMA(EMA(EMA(VAR2A,15),10),5)-25)*2;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2D:=EMA(VAR2C,7);
VAR2E:=(VAR2A+VAR2C)/2/1.1;
超短:EMA(VAR2E,3),COLORRED ;
短线:EMA(超短,5),COLORWHITE;
趋势线:EMA((VAR2B+VAR2D)/2,2) ,COLORYELLOW;
DRAWICON(CROSS(趋势线,0),0,1);
DRAWICON(CROSS(100,超短),100,2);
DRAWTEXT(趋势线>REF(趋势线,1)AND REF(趋势线,1)买入:CROSS(超短,短线);
DRAWTEXT(买入,超短,'←买入'),COLORYELLOW;
加仓:CROSS(超短,趋势线);
DRAWTEXT(加仓,趋势线,'←加仓'),COLORYELLOW; 

本公式实乃中短线朋友之佳品。使用方法如下:
1、超短、短线和趋势线是本公式的核心所在。
2、短线用法:当红线由下向上穿越白线时买进,反之卖出。红线在白线上方震荡可一路持股。
3、中线用法:A、黄线由下降趋势走平或拐头向上:B、红线和白线自下向上穿越
黄线,仿佛三线开花之态势时买进。如若出现拐头向下的三线开花势头,则是见好就收的最佳良机。
   

选股公式:

 VAR1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR2A:=((VAR27+VAR26+VAR20)/3+165)/4;
VAR2B:=(EMA(EMA(EMA(VAR2A,15),10),5)-25)*2;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2E:=(VAR2A+VAR2C)/2/1.1;
超短:=EMA(VAR2E,3);
短线:=EMA(超短,5);
CROSS(超短,短线);    VAR1:=MA(HHV(HIGH,485),17);
VAR2:=MA(HHV(HIGH,222),17);
VAR3:=MA(HHV(HIGH,96),17);
VAR4:=MA(LLV(LOW,485),17);
VAR5:=MA(LLV(LOW,222),17);
VAR6:=MA(LLV(LOW,96),17);
VAR7:=MA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,17);
VAR8:=MA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,17);
VAR9:=MA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,17);
VARA:=MA((VAR7*3+VAR8*2+VAR9)/6*1.738,17);
VARB:=IF(DATE<=1050531,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),N,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),N);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
VAR12:=1990831;
绝佳买点:=IF(DATE<=VAR12,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),N),100000000);
I:=IF(CLOSE
骤雨初晴:= ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
短线买:IF(绝佳买点>500 AND 绝佳买点>2500,1,0),COLORYELLOW,LINETHICK1;
中线买:IF(绝佳买点>10000 AND 绝佳买点>20000,2,0),COLORFF00FF,LINETHICK2;
倾家荡产买:IF(绝佳买点>30000 AND 绝佳买点>30000,3,0),COLORRED,LINETHICK3;
砸锅卖田买
Var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),3,1)/SMA(MAX(LOW-Var2,0),3,1)*100;
Var4:=EMA(IF(CLOSE*1.2,Var3*10,Var3/10),3);
Var5:=LLV(LOW,38);
Var6:=HHV(Var4,38);
Var7:=IF(LLV(LOW,90),1,0);
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7;
有庄的影子: STICKLINE(Var8,0,Var8,6,1) , COLORffaaff;
趋势线: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 , COLORaabbdd;
aa:=((ref(趋势线,1)=ref(趋势线,1)) or (ref(cross(-30,趋势线),1) and cross(趋势线,-30)) or 趋势线=-30;
aa1:=filter(aa,15) ;
drawtext(aa1,500,'砸锅卖田买'),coloryellow;
砸锅卖田买:if(aa,500,-30),coloryellow;
bb:=((ref(趋势线,1)-25) and 趋势线>=ref(趋势线,1)) or (ref(cross(-20,趋势线),1) and cross(趋势线,-20));
bb1:=filter(bb,15) ;
drawtext(bb1,300,'见底信号'),colorred;
见底信号:if(bb,300,-20),colorred;
cc:=((ref(趋势线,1)-30) and 趋势线>=ref(趋势线,1)) or (ref(cross(-25,趋势线),1) and cross(趋势线,-25));
cc1:=filter(cc,15) ;
drawtext(cc1,400,'莫错失机会'),color00ff00;
莫错失机会:if(cc,400,-25),color00ff00;
底部快显:if(cross(-20,趋势线),100,-20),linethick2,colorf0f000;
drawtext(cross(-20,趋势线),120,'★'),colorf0f000;
机会来临:if(cross(-25,趋势线),150,-25),linethick2,colorf00ff0;
drawtext(cross(-25,趋势线),170,'★'),colorf00ff0;
砸锅卖田等:if(cross(-30,趋势线),200,-30),linethick2,colorwhite;
drawtext(cross(-30,趋势线),220,'★'),colorwhite;
{见底信号:}-20,colorred,pointdot;
{莫要错失机会:}-25,colorlime,pointdot;
{砸锅卖田等着你:}-30,coloryellow,pointdot
{aa:=(趋势线<=13) and filter((趋势线<=13),15);} VAR1:=MA(HHV(HIGH,485),17);
VAR2:=MA(HHV(HIGH,222),17);
VAR3:=MA(HHV(HIGH,96),17);
VAR4:=MA(LLV(LOW,485),17);
VAR5:=MA(LLV(LOW,222),17);
VAR6:=MA(LLV(LOW,96),17);
VAR7:=MA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,17);
VAR8:=MA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,17);
VAR9:=MA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,17);
VARA:=MA((VAR7*3+VAR8*2+VAR9)/6*1.738,17);
VARB:=IF(DATE<=1050531,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),N,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),N);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
VAR12:=1990831;
绝佳买点:=IF(DATE<=VAR12,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),N),100000000);
I:=IF(CLOSE
骤雨初晴:= ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
短线买:IF(绝佳买点>500 AND 绝佳买点>2500,1,0),COLORYELLOW,LINETHICK1;
中线买:IF(绝佳买点>10000 AND 绝佳买点>20000,2,0),COLORFF00FF,LINETHICK2;
倾家荡产买:IF(绝佳买点>30000 AND 绝佳买点>30000,3,0),COLORRED,LINETHICK3;
砸锅卖田买
Var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),3,1)/SMA(MAX(LOW-Var2,0),3,1)*100;
Var4:=EMA(IF(CLOSE*1.2,Var3*10,Var3/10),3);
Var5:=LLV(LOW,38);
Var6:=HHV(Var4,38);
Var7:=IF(LLV(LOW,90),1,0);
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7;
有庄的影子: STICKLINE(Var8,0,Var8,6,1) , COLORffaaff;
趋势线: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 , COLORaabbdd;
aa:=((ref(趋势线,1)=ref(趋势线,1)) or (ref(cross(-30,趋势线),1) and cross(趋势线,-30)) or 趋势线=-30;
aa1:=filter(aa,15) ;
drawtext(aa1,500,'砸锅卖田买'),coloryellow;
砸锅卖田买:if(aa,500,-30),coloryellow;
bb:=((ref(趋势线,1)-25) and 趋势线>=ref(趋势线,1)) or (ref(cross(-20,趋势线),1) and cross(趋势线,-20));
bb1:=filter(bb,15) ;
drawtext(bb1,300,'见底信号'),colorred;
见底信号:if(bb,300,-20),colorred;
cc:=((ref(趋势线,1)-30) and 趋势线>=ref(趋势线,1)) or (ref(cross(-25,趋势线),1) and cross(趋势线,-25));
cc1:=filter(cc,15) ;
drawtext(cc1,400,'莫错失机会'),color00ff00;
莫错失机会:if(cc,400,-25),color00ff00;
底部快显:if(cross(-20,趋势线),100,-20),linethick2,colorf0f000;
drawtext(cross(-20,趋势线),120,'★'),colorf0f000;
机会来临:if(cross(-25,趋势线),150,-25),linethick2,colorf00ff0;
drawtext(cross(-25,趋势线),170,'★'),colorf00ff0;
砸锅卖田等:if(cross(-30,趋势线),200,-30),linethick2,colorwhite;
drawtext(cross(-30,趋势线),220,'★'),colorwhite;
{见底信号:}-20,colorred,pointdot;
{莫要错失机会:}-25,colorlime,pointdot;
{砸锅卖田等着你:}-30,coloryellow,pointdot
{aa:=(趋势线<=13) and filter((趋势线<=13),15);} VAR1:=MA(HHV(HIGH,485),17);
VAR2:=MA(HHV(HIGH,222),17);
VAR3:=MA(HHV(HIGH,96),17);
VAR4:=MA(LLV(LOW,485),17);
VAR5:=MA(LLV(LOW,222),17);
VAR6:=MA(LLV(LOW,96),17);
VAR7:=MA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,17);
VAR8:=MA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,17);
VAR9:=MA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,17);
VARA:=MA((VAR7*3+VAR8*2+VAR9)/6*1.738,17);
VARB:=IF(DATE<=1050531,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),N,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),N);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
VAR12:=1990831;
绝佳买点:=IF(DATE<=VAR12,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),N),100000000);
I:=IF(CLOSE
骤雨初晴:= ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
短线买:IF(绝佳买点>500 AND 绝佳买点>2500,1,0),COLORYELLOW,LINETHICK1;
中线买:IF(绝佳买点>10000 AND 绝佳买点>20000,2,0),COLORFF00FF,LINETHICK2;
倾家荡产买:IF(绝佳买点>30000 AND 绝佳买点>30000,3,0),COLORRED,LINETHICK3;
砸锅卖田买
Var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),3,1)/SMA(MAX(LOW-Var2,0),3,1)*100;
Var4:=EMA(IF(CLOSE*1.2,Var3*10,Var3/10),3);
Var5:=LLV(LOW,38);
Var6:=HHV(Var4,38);
Var7:=IF(LLV(LOW,90),1,0);
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7;
有庄的影子: STICKLINE(Var8,0,Var8,6,1) , COLORffaaff;
趋势线: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 , COLORaabbdd;
aa:=((ref(趋势线,1)=ref(趋势线,1)) or (ref(cross(-30,趋势线),1) and cross(趋势线,-30)) or 趋势线=-30;
aa1:=filter(aa,15) ;
drawtext(aa1,500,'砸锅卖田买'),coloryellow;
砸锅卖田买:if(aa,500,-30),coloryellow;
bb:=((ref(趋势线,1)-25) and 趋势线>=ref(趋势线,1)) or (ref(cross(-20,趋势线),1) and cross(趋势线,-20));
bb1:=filter(bb,15) ;
drawtext(bb1,300,'见底信号'),colorred;
见底信号:if(bb,300,-20),colorred;
cc:=((ref(趋势线,1)-30) and 趋势线>=ref(趋势线,1)) or (ref(cross(-25,趋势线),1) and cross(趋势线,-25));
cc1:=filter(cc,15) ;
drawtext(cc1,400,'莫错失机会'),color00ff00;
莫错失机会:if(cc,400,-25),color00ff00;
底部快显:if(cross(-20,趋势线),100,-20),linethick2,colorf0f000;
drawtext(cross(-20,趋势线),120,'★'),colorf0f000;
机会来临:if(cross(-25,趋势线),150,-25),linethick2,colorf00ff0;
drawtext(cross(-25,趋势线),170,'★'),colorf00ff0;
砸锅卖田等:if(cross(-30,趋势线),200,-30),linethick2,colorwhite;
drawtext(cross(-30,趋势线),220,'★'),colorwhite;
{见底信号:}-20,colorred,pointdot;
{莫要错失机会:}-25,colorlime,pointdot;
{砸锅卖田等着你:}-30,coloryellow,pointdot
{aa:=(趋势线<=13) and filter((趋势线<=13),15);}